aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/wireguard/CMakeLists.txt
diff options
context:
space:
mode:
authorArtem Glazychev <artem.glazychev@xored.com>2020-08-31 17:12:30 +0700
committerDamjan Marion <dmarion@me.com>2020-09-09 11:57:48 +0000
commitedca1325cf296bd0f5ff422fc12de2ce7a7bad88 (patch)
treefb12d12bd4193c5b2c7559d98aba9dc5d2f14e85 /src/plugins/wireguard/CMakeLists.txt
parentef80ad6bff03e3cc35950de0e15e4821ef3f7c04 (diff)
wireguard: initial implementation of wireguard protocol
Type: feature The main information about plugin you can see in README.md vpp# wireguard ? wireguard create wireguard create listen-port <port> private-key <key> src <IP> [generate-key] wireguard delete wireguard delete <interface> wireguard peer add wireguard peer add <wg_int> public-key <pub_key_other>endpoint <ip4_dst> allowed-ip <prefix>dst-port [port_dst] persistent-keepalive [keepalive_interval] wireguard peer remove wireguard peer remove <index> Change-Id: I85eb0bfc033ccfb2045696398d8a108b1c64b8d9 Signed-off-by: Artem Glazychev <artem.glazychev@xored.com> Signed-off-by: Damjan Marion <damarion@cisco.com> Signed-off-by: Jim Thompson <jim@netgate.com> Signed-off-by: Neale Ranns <nranns@cisco.com> Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/plugins/wireguard/CMakeLists.txt')
-rwxr-xr-xsrc/plugins/wireguard/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/src/plugins/wireguard/CMakeLists.txt b/src/plugins/wireguard/CMakeLists.txt
new file mode 100755
index 00000000000..db5bb2d8910
--- /dev/null
+++ b/src/plugins/wireguard/CMakeLists.txt
@@ -0,0 +1,54 @@
+
+# Copyright (c) 2020 Doc.ai and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+if (OPENSSL_VERSION VERSION_LESS 1.1.0)
+ return()
+endif()
+
+list(APPEND WG_BLAKE_SOURCES
+ blake/blake2s.h
+ blake/blake2s.c
+)
+
+add_vpp_plugin(wireguard
+ SOURCES
+ ${WG_BLAKE_SOURCES}
+ wireguard.c
+ wireguard.h
+ wireguard_if.c
+ wireguard_if.h
+ wireguard_input.c
+ wireguard_output_tun.c
+ wireguard_key.c
+ wireguard_key.h
+ wireguard_cli.c
+ wireguard_messages.h
+ wireguard_noise.c
+ wireguard_noise.h
+ wireguard_send.c
+ wireguard_send.h
+ wireguard_cookie.c
+ wireguard_cookie.h
+ wireguard_peer.c
+ wireguard_peer.h
+ wireguard_timer.c
+ wireguard_timer.h
+ wireguard_index_table.c
+ wireguard_index_table.h
+ wireguard_api.c
+
+ API_FILES
+ wireguard.api
+
+)