aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/wireguard/CMakeLists.txt
diff options
context:
space:
mode:
authorKlement Sekera <ksekera@cisco.com>2021-04-20 19:21:36 +0200
committerDamjan Marion <dmarion@me.com>2021-05-21 21:06:34 +0000
commitefd4d702105bf86cd74ae777668d2c17e3a85bbc (patch)
treee49195d5b19d70c45eb6a28f0bc15c9d7b2c7f48 /src/plugins/wireguard/CMakeLists.txt
parenta42c41be4eed3e1ce2a42038b07ce1d3420891cd (diff)
bfd: use vnet crypto
Type: improvement Change-Id: I873a99c1258a97ed5ed195b9756e8302f865e7f0 Signed-off-by: Klement Sekera <ksekera@cisco.com> Signed-off-by: Filip Tehlar <ftehlar@cisco.com>
Diffstat (limited to 'src/plugins/wireguard/CMakeLists.txt')
-rwxr-xr-xsrc/plugins/wireguard/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/plugins/wireguard/CMakeLists.txt b/src/plugins/wireguard/CMakeLists.txt
index db74f9cdce0..6dddc67298d 100755
--- a/src/plugins/wireguard/CMakeLists.txt
+++ b/src/plugins/wireguard/CMakeLists.txt
@@ -16,6 +16,8 @@ if (OPENSSL_VERSION VERSION_LESS 1.1.0)
return()
endif()
+include_directories(${OPENSSL_INCLUDE_DIR})
+
list(APPEND WG_BLAKE_SOURCES
blake/blake2s.h
blake/blake2s.c
@@ -49,6 +51,8 @@ add_vpp_plugin(wireguard
wireguard_index_table.h
wireguard_api.c
+ LINK_LIBRARIES ${OPENSSL_LIBRARIES}
+
API_FILES
wireguard.api