aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/wireguard/CMakeLists.txt
diff options
context:
space:
mode:
authorBenoît Ganne <bganne@cisco.com>2023-01-04 17:56:58 +0100
committerDave Wallace <dwallacelf@gmail.com>2023-01-10 20:51:05 +0000
commitf457f1fa024ac8cd4f80885aa92b2fc22db882db (patch)
tree5f6b2eb4d58eb8b61718a2c4b62b94d5e1ecaa85 /src/plugins/wireguard/CMakeLists.txt
parent9bc72ac8de6dcc74aa82fa6c3223e9f93b2dc3c2 (diff)
build: do not link with libssl if not needed
In most cases we only need OpenSSL libcrypto (crypto primitives) but not libssl (tls). Type: improvement Change-Id: I9dce27d23d65bf46aea2d0f8aaf417240701efcc Signed-off-by: Benoît Ganne <bganne@cisco.com>
Diffstat (limited to 'src/plugins/wireguard/CMakeLists.txt')
-rw-r--r--src/plugins/wireguard/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/wireguard/CMakeLists.txt b/src/plugins/wireguard/CMakeLists.txt
index 31f09f1d8e3..581fcf23860 100644
--- a/src/plugins/wireguard/CMakeLists.txt
+++ b/src/plugins/wireguard/CMakeLists.txt
@@ -54,7 +54,7 @@ add_vpp_plugin(wireguard
wireguard_index_table.h
wireguard_api.c
- LINK_LIBRARIES ${OPENSSL_LIBRARIES}
+ LINK_LIBRARIES ${OPENSSL_CRYPTO_LIBRARIES}
API_FILES
wireguard.api