aboutsummaryrefslogtreecommitdiffstats
path: root/src/vcl/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2018-08-24 13:37:45 +0200
committerDamjan Marion <damarion@cisco.com>2018-09-02 11:24:12 +0200
commit855e26868ff8b9e6d00ca4d69ce6c9fdc0f2e121 (patch)
tree84668d629d4bee4244d446dec7c94154211c65b5 /src/vcl/CMakeLists.txt
parentedc4387602eb935c6e1702a713f0a5665c12d467 (diff)
Switch to cmake
Change-Id: I982b69390c55b5ffbd744f355efc0aaf425b360c Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/vcl/CMakeLists.txt')
-rw-r--r--src/vcl/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/vcl/CMakeLists.txt b/src/vcl/CMakeLists.txt
index b6d496418d5..b0a283ce1fe 100644
--- a/src/vcl/CMakeLists.txt
+++ b/src/vcl/CMakeLists.txt
@@ -26,6 +26,15 @@ add_vpp_library(vppcom
vppinfra svm vlibmemoryclient rt pthread
)
+add_vpp_library(vcl_ldpreload
+ SOURCES
+ ldp_socket_wrapper.c
+ ldp.c
+
+ LINK_LIBRARIES
+ vppinfra svm vlibmemoryclient rt pthread vppcom
+)
+
add_vpp_headers(vcl
ldp.h
vcl_event.h