aboutsummaryrefslogtreecommitdiffstats
path: root/src/vlibapi/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2018-08-24 21:36:42 +0200
committerDamjan Marion <dmarion@me.com>2018-08-25 09:55:17 +0000
commit2bfdda76d8b1cffcd8e30ca6855f293b1b1953c5 (patch)
treed96a06e0833d4a513296ee5c8bd036f0e7f36118 /src/vlibapi/CMakeLists.txt
parent0219b8dfbf25090214573394cf2c9e5e968cfa9a (diff)
cmake: add more headers to the install list
Change-Id: I3a0f48381232fcac1727034aa6d2504a8d1edb04 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/vlibapi/CMakeLists.txt')
-rw-r--r--src/vlibapi/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/vlibapi/CMakeLists.txt b/src/vlibapi/CMakeLists.txt
new file mode 100644
index 00000000000..27029bff344
--- /dev/null
+++ b/src/vlibapi/CMakeLists.txt
@@ -0,0 +1,19 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+vpp_add_header_files(vlibapi
+ api_helper_macros.h
+ api.h
+ vat_helper_macros.h
+ api_common.h
+)