aboutsummaryrefslogtreecommitdiffstats
path: root/src/vlibmemory/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <neale.ranns@cisco.com>2018-08-20 07:41:52 -0700
committerDamjan Marion <dmarion@me.com>2018-08-20 15:05:07 +0000
commit5ff0e0b1864fa646accea1ee344cbd8db07605fe (patch)
tree7f6155f5b1641c4e23c8d27fecfbc6a6e649fb82 /src/vlibmemory/CMakeLists.txt
parent23722e6bfa9e67e87de9b09d14fafe84d2a8f029 (diff)
CMake: generate .json from .api files
Change-Id: Ic18aa0fb42a72b5e0ebbfbebdefc7582cb46b5ea Signed-off-by: Neale Ranns <neale.ranns@cisco.com>
Diffstat (limited to 'src/vlibmemory/CMakeLists.txt')
-rw-r--r--src/vlibmemory/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/vlibmemory/CMakeLists.txt b/src/vlibmemory/CMakeLists.txt
index 3459f03db1b..a37fc9fe451 100644
--- a/src/vlibmemory/CMakeLists.txt
+++ b/src/vlibmemory/CMakeLists.txt
@@ -11,8 +11,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-vpp_generate_api_header(memclnt.api)
-add_custom_target(vlibmemory_api_headers DEPENDS memclnt.api.h)
+vpp_add_api_files(vlibmemory_api_headers
+ memclnt.api
+)
add_library (vlibmemory SHARED
memory_api.c