aboutsummaryrefslogtreecommitdiffstats
path: root/src/vlibmemory/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2018-07-30 12:45:07 +0200
committerFlorin Coras <florin.coras@gmail.com>2018-08-17 22:14:39 +0000
commit612dd6a955e44d2c0fed1801fb8de585ca695c63 (patch)
treea49c3004a7122077a884dce483daebc280199761 /src/vlibmemory/CMakeLists.txt
parent5d82d2f1495e189c4687a6462850cbbb3ea38b17 (diff)
CMake as an alternative to autotools (experimental)
Change-Id: Ibc59323e849810531dd0963e85493efad3b86857 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/vlibmemory/CMakeLists.txt')
-rw-r--r--src/vlibmemory/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/vlibmemory/CMakeLists.txt b/src/vlibmemory/CMakeLists.txt
new file mode 100644
index 00000000000..3459f03db1b
--- /dev/null
+++ b/src/vlibmemory/CMakeLists.txt
@@ -0,0 +1,41 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+vpp_generate_api_header(memclnt.api)
+add_custom_target(vlibmemory_api_headers DEPENDS memclnt.api.h)
+
+add_library (vlibmemory SHARED
+ memory_api.c
+ memory_shared.c
+ memory_client.c
+ socket_api.c
+ vlib_api.c
+ vlib_api_cli.c
+ ../vlibapi/api_shared.c
+ ../vlibapi/node_serialize.c
+)
+target_link_libraries (vlibmemory vppinfra svm vlib)
+add_dependencies(vlibmemory vlibmemory_api_headers)
+install (TARGETS vlibmemory DESTINATION lib)
+
+add_library (vlibmemoryclient SHARED
+ memory_shared.c
+ memory_client.c
+ socket_client.c
+ ../vlibapi/api_shared.c
+ ../vlibapi/node_serialize.c
+)
+
+target_link_libraries (vlibmemoryclient vppinfra svm vlib)
+add_dependencies(vlibmemoryclient vlibmemory_api_headers)
+install (TARGETS vlibmemoryclient DESTINATION lib)