aboutsummaryrefslogtreecommitdiffstats
path: root/src/vlibmemory/CMakeLists.txt
diff options
context:
space:
mode:
authorBenoît Ganne <bganne@cisco.com>2022-03-04 17:17:04 +0100
committerOle Tr�an <otroan@employees.org>2022-03-23 18:23:29 +0000
commit7f9256e31c13fdfb640eff9d7775bc50b4396543 (patch)
tree3d799496f125655ca973d6da1c99fabc12787824 /src/vlibmemory/CMakeLists.txt
parent8296a1d043ce6584561dabbc671087e040a3ae13 (diff)
api: better segregate client and server code
- move memory and server specific vl_msg_api_handler_with_vm_node() to memory server code only - keep api_global_main static Apart from being cleaner, this also helps avoiding symbols conflict when both client and server libs are loaded in the same process, as is done by the prom plugin. Those symbols conflict confuse ASan and can be nasty to debug. Type: improvement Change-Id: Iaf58596cc753ad8d3fedd8d65c4bf480ac129c2c Signed-off-by: Benoît Ganne <bganne@cisco.com>
Diffstat (limited to 'src/vlibmemory/CMakeLists.txt')
-rw-r--r--src/vlibmemory/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/vlibmemory/CMakeLists.txt b/src/vlibmemory/CMakeLists.txt
index 488a0d7b827..d14e9cad954 100644
--- a/src/vlibmemory/CMakeLists.txt
+++ b/src/vlibmemory/CMakeLists.txt
@@ -15,8 +15,6 @@ add_vpp_library (vlibmemory
SOURCES
memory_api.c
memory_shared.c
- memory_client.c
- socket_client.c
socket_api.c
memclnt_api.c
vlib_api_cli.c