aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2020-02-03 10:55:09 +0000
committerDamjan Marion <dmarion@me.com>2020-02-04 09:44:58 +0000
commit03ce46219cd0fabfd4918822c5b9fed9ef880de8 (patch)
treef33c291dba25bcbe856602e6c63ce9d8ef4cc96c /src/vnet/CMakeLists.txt
parent0860b2e19365c092f10dd1ce639caaded0e87ded (diff)
teib: Rename NHRP to TEIB
Type: refactor The Tunnel Endpoint Informatiob Base (TEIB) is a better description of what it is (a mapping between tunnel endpoint address, in the overlay, and next-hop address, in the underlay) whereas NHRP is one instanc eof a control protocol that might add such endpoints. Signed-off-by: Neale Ranns <nranns@cisco.com> Change-Id: Idcb2ad0b6543d3e5d9f6e96f9d14dafb5ce2aa85
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 6f9f6bcc974..5a9ae4c1a7f 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -1517,20 +1517,20 @@ list(APPEND VNET_HEADERS
list(APPEND VNET_API_FILES pci/pci_types.api)
##############################################################################
-# NHRP
+# Tunnel Endpoint Information Base
##############################################################################
list (APPEND VNET_SOURCES
- nhrp/nhrp_api.c
- nhrp/nhrp_cli.c
- nhrp/nhrp.c
+ teib/teib_api.c
+ teib/teib_cli.c
+ teib/teib.c
)
list(APPEND VNET_HEADERS
- nhrp/nhrp.h
+ teib/teib.h
)
-list(APPEND VNET_API_FILES nhrp/nhrp.api)
+list(APPEND VNET_API_FILES teib/teib.api)
##############################################################################
# ARP/ND