aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2020-04-12 08:31:39 -0400
committerDave Barach <openvpp@barachs.net>2020-04-15 11:00:26 +0000
commit1bd2c019eba5c893d634cc496bd6d54c00020d7e (patch)
tree99595a7f0818e07034a0a9a7b158d4157a98b3ed /src/vnet/CMakeLists.txt
parent69eeadc03f30c9fb3fe1bb7e2eeb6b04d1bcc596 (diff)
misc: refactor calc_checksums
Merge two mildly incompatible static inlines, and rename the results vnet_calc_checksums_inline (...). The resulting inline has three additional parameters: int is_ip4, int is_ip6, and int with_gso. All calls manage to pass one or more as compile-time constants, which causes a certain amount of code to disappear in each instantiation. Type: refactor Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I1a2a0e353b9a7bca20bc81318e8c915617261e1a
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index f8948de5d5e..69e041b0d12 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -56,6 +56,7 @@ list(APPEND VNET_HEADERS
handoff.h
interface.h
interface_funcs.h
+ interface_output.h
ip/ip4_to_ip6.h
ip/ip6_to_ip4.h
ip/ip_types_api.h