aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2021-09-14 18:54:45 -0700
committerOle Tr�an <otroan@employees.org>2021-09-27 07:04:51 +0000
commit248210c6ca1716ee2c5e6c974051218930fa4c26 (patch)
tree5c4e8e1c53800e8ec43da7a8dbc4fbe73e5c9672 /src/vnet/CMakeLists.txt
parent1b6c7932a8feb419aae73a00a6784d7c110decdc (diff)
misc: move part of vpe apis to vlibmemory
VPE apis are actually vlib apis. This moves those that are not tightly coupled with vapi to vlib_api Type: refactor Signed-off-by: Florin Coras <fcoras@cisco.com> Change-Id: I456a64ce49a0cdeff4a0931c6ea513cb639f683e Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 68133308b76..2dbde7c5259 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -1520,6 +1520,12 @@ add_vpp_library (vatclient
DEPENDS api_headers
)
+add_vat_test_library(vnet
+ ip/ip_test.c
+ arp/arp_test.c
+ ip6-nd/ip6_nd_test.c
+)
+
##############################################################################
# VAT2 plugins
##############################################################################