aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Wallace <dwallacelf@gmail.com>2022-02-23 17:15:14 -0500
committerDave Wallace <dwallacelf@gmail.com>2022-02-23 17:15:14 -0500
commit40cfc1560ee6fa11e4d6c74e9730541a8a45b68a (patch)
tree12ccef5fdad06b9f75d3958e39b90f65372da0d1 /src/vnet/CMakeLists.txt
parent1b026cb028d6bcf24d243f633352b7ac58ce5c00 (diff)
build: export missing header files required by hicn_plugin
- HICN project's hicn_plugin requires vnet header files fib/fib_entry_track.h and udp/udp_encap.h to be included in build-root/install-vpp*-*/vpp/include/vnet Type: fix Signed-off-by: Dave Wallace <dwallacelf@gmail.com> Change-Id: Iabd3f8fe0aee8d727758fc6ef202e859d68d63a3
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index af4f64aef33..88ef4cca7b9 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -679,6 +679,7 @@ list(APPEND VNET_MULTIARCH_SOURCES
list(APPEND VNET_HEADERS
udp/udp_error.def
udp/udp.h
+ udp/udp_encap.h
udp/udp_packet.h
udp/udp_inlines.h
udp/udp_local.h
@@ -1203,6 +1204,7 @@ list(APPEND VNET_SOURCES
list(APPEND VNET_HEADERS
fib/fib.h
fib/fib_api.h
+ fib/fib_entry_track.h
fib/ip4_fib.h
fib/ip4_fib_8.h
fib/ip4_fib_16.h