aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorMohsin Kazmi <sykazmi@cisco.com>2021-06-30 18:26:25 +0000
committerDamjan Marion <dmarion@me.com>2021-09-20 11:11:02 +0000
commit41b23bc9554a134aee37b430ebf5553cc3260624 (patch)
tree9094c812a8833a37292244e9c2023d466d99a606 /src/vnet/CMakeLists.txt
parente3cf4d0cf3b83f912474220ff52dfedc5a432084 (diff)
hash: add support for hashing infra
Type: feature Signed-off-by: Mohsin Kazmi <sykazmi@cisco.com> Change-Id: I3652ae275385d9b1eb1b11f418e3a7e5fef2f556
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 78a2ba77c0e..68133308b76 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -882,6 +882,19 @@ list(APPEND VNET_HEADERS
list(APPEND VNET_API_FILES ipfix-export/ipfix_export.api)
##############################################################################
+# HASH
+##############################################################################
+list(APPEND VNET_SOURCES
+ hash/hash.c
+ hash/cli.c
+ hash/crc32_5tuple.c
+)
+
+list(APPEND VNET_HEADERS
+ hash/hash.h
+)
+
+##############################################################################
# GSO
##############################################################################
list(APPEND VNET_SOURCES