aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2021-08-11 13:54:14 +0200
committerNeale Ranns <neale@graphiant.com>2021-08-13 18:07:23 +0000
commit8034a36a9cedc95f6762bf0a07f6617d0bf69bfe (patch)
treed22313b64c46a26c5c46fcf8c2cb799b02e92197 /src/vnet/CMakeLists.txt
parentd170681b24724c522adaf1e2f4f0e1f3289dbf82 (diff)
ip: source address selection
Implement a simple source address selection algorithm for IPv4 and IPv6. IPv6 does not yet implement RFC6724 but supports link-locals. ping now chooses correct source address for link-local destination. Added ping support for link-local multicast (e.g. allnodes). Type: feature Signed-off-by: Ole Troan <ot@cisco.com> Change-Id: I1a3382c1f7d4ace0386c2c19e4e47b045b73a3ed Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 66a4abc3a41..18e162030b0 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -73,6 +73,7 @@ list(APPEND VNET_HEADERS
util/refcount.h
format_fns.h
ip/ip_format_fns.h
+ ip/ip_sas.h
ethernet/ethernet_format_fns.h
)
@@ -413,6 +414,7 @@ list(APPEND VNET_SOURCES
ip/punt.c
ip/punt_node.c
ip/vtep.c
+ ip/ip_sas.c
)
list(APPEND VNET_MULTIARCH_SOURCES