aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorHadi Rayan Al-Sandid <halsandi@cisco.com>2024-08-01 17:10:54 +0200
committerBeno�t Ganne <bganne@cisco.com>2024-08-22 08:00:52 +0000
commit8629336fa502b5859ed46bcc1976c824470092b3 (patch)
tree72c5757fba8d7009111a24cd6f814cf13b386bec /src/vnet/CMakeLists.txt
parent85ce93160fa71c5e6fb9140704c07e6d8989889d (diff)
misc: move osi to plugin
Type: refactor This patch moves osi into a plugin, and also modifies the init functions of llc and snap to preserve init order dependency (llc_init --> osi_init --> snap_init). While the initial intent was to move osi/llc/snap together into a single plugin, there exists a dependency on llc in vnet/ethernet, which would require further refactoring and testing work. Change-Id: Ic0eff030ee29c8d316c0e0fe13931451aa193527 Signed-off-by: Hadi Rayan Al-Sandid <halsandi@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index ca35d0dba4e..b7a1bbe58c9 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -607,19 +607,6 @@ list(APPEND VNET_HEADERS
)
##############################################################################
-# Layer 3 protocol: osi
-##############################################################################
-list(APPEND VNET_SOURCES
- osi/node.c
- osi/osi.c
- osi/pg.c
-)
-
-list(APPEND VNET_HEADERS
- osi/osi.h
-)
-
-##############################################################################
# Layer 4 protocol: tcp
##############################################################################
list(APPEND VNET_SOURCES