aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorKlement Sekera <ksekera@cisco.com>2019-06-24 11:52:49 +0000
committerOle Trøan <otroan@employees.org>2019-09-25 08:23:04 +0000
commit896c896a3c4ed563a270281ff8b50fd253f4833f (patch)
tree801170d6b2d3c7ae4ff782e7f7088b4d6146d393 /src/vnet/CMakeLists.txt
parent5e2f84d2cf97a6efa89c1c4bbf80de6a8f03d2a8 (diff)
ip: refactor reassembly
this is a preparation step for introducing other reassembly types Type: refactor Change-Id: I197e299dbd729b00eead31667913b8ceff915d63 Signed-off-by: Klement Sekera <ksekera@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 1e51f3d7102..aaa16d8389b 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -431,7 +431,7 @@ list(APPEND VNET_SOURCES
ip/ip4_pg.c
ip/ip4_source_and_port_range_check.c
ip/ip4_source_check.c
- ip/ip4_reassembly.c
+ ip/reass/ip4_full_reass.c
ip/ip6_format.c
ip/ip6_forward.c
ip/ip6_ll_table.c
@@ -441,7 +441,7 @@ list(APPEND VNET_SOURCES
ip/ip6_input.c
ip/ip6_neighbor.c
ip/ip6_pg.c
- ip/ip6_reassembly.c
+ ip/reass/ip6_full_reass.c
ip/rd_cp.c
ip/ip_neighbor.c
ip/ip_api.c
@@ -461,9 +461,9 @@ list(APPEND VNET_SOURCES
list(APPEND VNET_MULTIARCH_SOURCES
ip/ip4_source_check.c
ip/ip4_punt_drop.c
- ip/ip4_reassembly.c
+ ip/reass/ip4_full_reass.c
ip/ip6_hop_by_hop.c
- ip/ip6_reassembly.c
+ ip/reass/ip6_full_reass.c
ip/ip6_input.c
ip/ip6_punt_drop.c
ip/punt_node.c