aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorArthur de Kerhor <arthurdekerhor@gmail.com>2021-05-20 11:48:00 +0200
committerFlorin Coras <florin.coras@gmail.com>2021-05-29 18:13:01 +0000
commit8a6f5d394c69eba3bfaddfe36a93d1013cba3ce3 (patch)
tree4adb54d52b2f246fc7d2820fb959e63bbcae7de3 /src/vnet/CMakeLists.txt
parentb740fdc8ff7f58637524e999d5fe01b8b010810d (diff)
udp: add udp decapsulation
Possibility to register a port via CLI or API to decap incoming UDP packets: - For CLI, a user needs to specify the inner protocol (only MPLS supported for now) - For API, the protocol is specified by index Added unittests Type: feature Change-Id: Ifedd86d8db2e355b7618472554fd67d77a13a4aa Signed-off-by: Arthur de Kerhor <arthurdekerhor@gmail.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 47d7b56f0fd..a24b87bd6e0 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -660,6 +660,7 @@ list(APPEND VNET_SOURCES
udp/udp_pg.c
udp/udp_encap_node.c
udp/udp_encap.c
+ udp/udp_decap.c
udp/udp_api.c
)