aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <neale@graphiant.com>2020-12-21 08:29:34 +0000
committerOle Tr�an <otroan@employees.org>2021-02-15 17:27:48 +0000
commit8f5fef2c78b95de1a636ce27111722b71702212a (patch)
treea0ebd0189969ccae1f0bdd7c1a9c18dd7a066f2e /src/vnet/CMakeLists.txt
parent54be0cc044f445853fae7b8995c477605250af16 (diff)
ip: Path MTU
Type: feature Support setting the MTU for a peer on an interface. The minimum value of the path and interface MTU is used at forwarding time. the path MTU is specified for a given peer, by address and table-ID. In the forwarding plane the MTU is enfored either: 1 - if the peer is attached, then the MTU is set on the peer's adjacency 2 - if the peer is not attached, it is remote, then a DPO is added to the peer's FIB entry to perform the necessary fragmentation. Signed-off-by: Neale Ranns <neale@graphiant.com> Change-Id: I8b9ea6a07868b50e97e2561f18d9335407dea7ae
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 0e1d9c44b05..38aeda5be93 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -415,6 +415,8 @@ list(APPEND VNET_SOURCES
ip/ip_interface.c
ip/ip_init.c
ip/ip_in_out_acl.c
+ ip/ip_path_mtu.c
+ ip/ip_path_mtu_node.c
ip/ip_punt_drop.c
ip/ip_types.c
ip/lookup.c
@@ -437,6 +439,7 @@ list(APPEND VNET_MULTIARCH_SOURCES
ip/ip6_punt_drop.c
ip/punt_node.c
ip/ip_in_out_acl.c
+ ip/ip_path_mtu_node.c
)
list(APPEND VNET_HEADERS