aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2019-09-13 17:47:50 -0400
committerFlorin Coras <florin.coras@gmail.com>2019-09-20 15:55:25 +0000
commit9137e5400699bed9f7c0095187839a8b38273100 (patch)
treeb4f0b34583c8e4add09b34e8a4c52a5606b2dc55 /src/vnet/CMakeLists.txt
parent864d857c6c223be8ec11c588d65e8c5c2e211814 (diff)
misc: classifier-based packet trace filter
See .../src/vnet/classify/trace_classify.h for the business end of the scheme. It would be best to hash pkts, prefetch buckets, and do the primary table lookups two at a time. The inline as given works, but perf tuning will be required. "At least it works..." Add "classify filter" debug cli, for example: classify filter mask l3 ip4 src dst \ match l3 ip4 dst 192.168.2.10 src 192.168.1.10 Add "pcap rx | tx trace ... filter" to use the current classify filter chain Patch includes sphinx documentation and doxygen tags. Next step: device-driver integration Type: feature Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I05b1358a769f61e6d32470e0c87058f640486b26
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 2a783810fdd..1e51f3d7102 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -384,6 +384,7 @@ list(APPEND VNET_API_FILES lldp/lldp.api)
##############################################################################
list(APPEND VNET_SOURCES
classify/vnet_classify.c
+ classify/trace_classify.h
classify/ip_classify.c
classify/in_out_acl.c
classify/policer_classify.c
@@ -400,6 +401,7 @@ list(APPEND VNET_MULTIARCH_SOURCES
list(APPEND VNET_HEADERS
classify/vnet_classify.h
+ classify/trace_classify.h
classify/in_out_acl.h
classify/policer_classify.h
classify/flow_classify.h