aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-12-04 06:11:00 +0000
committerNeale Ranns <neale@graphiant.com>2021-03-16 12:12:23 +0000
commit976b259be2ce9725f1d6756c14ff81069634a396 (patch)
treef4117b32e9230e5c313474a158dbfa847943b99d /src/vnet/CMakeLists.txt
parent400ce717ac043ceec404103dbaa87dd17d92feb7 (diff)
fib: Allow the creation of new source on the API
Type: feature an client can dump the existing sources, examine their priorities, then define thier own source. Usefull if a client wants to distingusih between say, static, ospf, bgp, etc routes it has added over the API. Signed-off-by: Neale Ranns <nranns@cisco.com> Signed-off-by: Alexander Chernavin <achernavin@netgate.com> Change-Id: I5158b4fa1ebe87381ff8707bb173217f56ea274a
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index eecb18c937b..1ff2a8c7e58 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -1214,7 +1214,10 @@ list(APPEND VNET_HEADERS
fib/fib_source.h
)
-list(APPEND VNET_API_FILES fib/fib_types.api)
+list(APPEND VNET_API_FILES
+ fib/fib_types.api
+ fib/fib.api
+)
##############################################################################
# ADJ