aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2019-08-20 07:09:31 -0700
committerFlorin Coras <florin.coras@gmail.com>2019-08-21 16:07:12 +0000
commita436a42221280888acd09858c7353e694c359bca (patch)
treed403a3a6c5240477da82b3df0650567f8b13c081 /src/vnet/CMakeLists.txt
parentc33eddebe8e390ed3d5b817e7e6017ae8a543097 (diff)
tcp: add option for always on event logging
Type: feature Add option to always compile in debugging infra. Debug verbosity can be controlled via configuration updatable via cli. Compile time inclusion and configuration of event logging verbosity is still available in order to minimize event logging impact. Change-Id: I9d946efe9fa4204fdace1adb1d6588c97b5ae758 Signed-off-by: Florin Coras <fcoras@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index beef1c99b38..3ad53f988bf 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -633,6 +633,7 @@ list(APPEND VNET_SOURCES
tcp/tcp_newreno.c
tcp/tcp_cubic.c
tcp/tcp_bt.c
+ tcp/tcp_debug.c
tcp/tcp.c
)