aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2020-07-14 18:30:05 -0400
committerDamjan Marion <dmarion@me.com>2020-07-16 21:39:23 +0000
commitac0326fc5ae7ac4a8126bbc2f496a92fcfe4755e (patch)
tree3bb8d7fac43b165ccd6dd106b597fd733e5b28b8 /src/vnet/CMakeLists.txt
parent9a0f2a5e7f678de58807fd49d47deec367656715 (diff)
adl: move allow/deny list function to plugin
Provide binary API compatibility support for the "cop" APIs until vpp 21.01. Change the deprecation date in map.api to vpp 21.01. Type: refactor Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I0e60d96de4ae9ae4448f134cf257934126f3b760
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt19
1 files changed, 3 insertions, 16 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index bd1b75b54a1..9ee0eeba070 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2018 Cisco and/or its affiliates.
+# Copyright (c) 2018-2020 Cisco and/or its affiliates.
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at:
@@ -105,26 +105,13 @@ list(APPEND VNET_API_FILES
)
##############################################################################
-# Cop - junk filter
+# Binary API compatibility until vpp 20.12, see the ADL plugin...
##############################################################################
+
list(APPEND VNET_SOURCES
- cop/cop.c
- cop/node1.c
- cop/ip4_whitelist.c
- cop/ip6_whitelist.c
cop/cop_api.c
)
-list(APPEND VNET_MULTIARCH_SOURCES
- cop/node1.c
- cop/ip4_whitelist.c
- cop/ip6_whitelist.c
-)
-
-list(APPEND VNET_HEADERS
- cop/cop.h
-)
-
list(APPEND VNET_API_FILES cop/cop.api)
##############################################################################