aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Luke <chrisy@flirble.org>2020-01-15 20:30:04 -0500
committerChris Luke <chrisy@flirble.org>2020-01-15 20:30:04 -0500
commitc171d01cdb5183c8bf640951e94af6b1fd5e3efc (patch)
treebdfcb19b0ccac0baa25b29e4ebf5fe8f085673f6 /src/vnet/CMakeLists.txt
parentbed0f4a4335ca59f3664f66fe1ea60f1e23fff7f (diff)
build: Add missing version.h dependency in vnet
Two modules in vnet include vpp/app/version.h but there is no explicit build dependency for this generated file. This leaves a race condition in the build system that the Coverity build has recently started triggering. Change-Id: I8e2bb32feeb16e1bdd8efb0d2633cfdba60f51aa Type: fix Signed-off-by: Chris Luke <chrisy@flirble.org>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 56db74265cc..c2a0dd54401 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -1583,7 +1583,7 @@ add_vpp_library(vnet
INSTALL_HEADERS ${VNET_HEADERS}
API_FILES ${VNET_API_FILES}
LINK_LIBRARIES vppinfra svm vlib ${OPENSSL_LIBRARIES}
- DEPENDS api_headers
+ DEPENDS vpp_version_h api_headers
)
##############################################################################