aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Luong <sluong@cisco.com>2020-07-27 10:06:58 -0700
committerOle Trøan <otroan@employees.org>2020-08-14 08:15:31 +0000
commitc3ed1c99134d063dff03c4babe0ebbf5cc0e8ab2 (patch)
tree0a5fa53b402f4995cfb345f9134a23f88fe86a08 /src/vnet/CMakeLists.txt
parent2f630188b91b58eca379c9cc9944986af3e00ae5 (diff)
ip: add VNET_IP_TABLE_ADD_DEL_FUNCTION
vrf table may be dynamically added or deleted. When the table is deleted, clients who use the corresponding vrf table may need a callback to do the clean up. The mechanism added here is cloned from VNET_SW_INTERFACE_ADD_DEL_FUNCTION. Type: improvement Signed-off-by: Steven Luong <sluong@cisco.com> Change-Id: I08635c715cd7361a6c359b90890dd3545b0da94c
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index e4182186e60..7757301c73a 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -489,6 +489,7 @@ list(APPEND VNET_HEADERS
ip/ip6_hop_by_hop_packet.h
ip/ip6_packet.h
ip/ip.h
+ ip/ip_table.h
ip/ip_interface.h
ip/ip_packet.h
ip/ip_source_and_port_range_check.h