aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-02-07 07:26:12 -0800
committerDamjan Marion <dmarion@me.com>2019-06-18 13:54:35 +0000
commitc87b66c86201458c0475d50c6e93f1497f9eec2e (patch)
tree57bf69c2adb85a93b26a86b5a1110e4290e7f391 /src/vnet/CMakeLists.txt
parent097fa66b986f06281f603767d321ab13ab6c88c3 (diff)
ipsec: ipsec-tun protect
please consult the new tunnel proposal at: https://wiki.fd.io/view/VPP/IPSec Type: feature Change-Id: I52857fc92ae068b85f59be08bdbea1bd5932e291 Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt25
1 files changed, 3 insertions, 22 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 5465d717f8c..462ced4ae23 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -566,6 +566,8 @@ list(APPEND VNET_SOURCES
ipsec/ipsec_sa.c
ipsec/ipsec_spd.c
ipsec/ipsec_spd_policy.c
+ ipsec/ipsec_tun.c
+ ipsec/ipsec_tun_in.c
ipsec/esp_format.c
ipsec/esp_encrypt.c
ipsec/esp_decrypt.c
@@ -582,6 +584,7 @@ list(APPEND VNET_MULTIARCH_SOURCES
ipsec/ipsec_if_in.c
ipsec/ipsec_output.c
ipsec/ipsec_input.c
+ ipsec/ipsec_tun_in.c
)
list(APPEND VNET_API_FILES ipsec/ipsec.api)
@@ -847,28 +850,6 @@ list(APPEND VNET_HEADERS
list(APPEND VNET_API_FILES vxlan-gpe/vxlan_gpe.api)
##############################################################################
-# Tunnel protocol: ipsec+gre
-##############################################################################
-list(APPEND VNET_SOURCES
- ipsec-gre/ipsec_gre.c
- ipsec-gre/node.c
- ipsec-gre/interface.c
- ipsec-gre/ipsec_gre_api.c
-)
-
-list(APPEND VNET_MULTIARCH_SOURCES
- ipsec-gre/node.c
- ipsec-gre/ipsec_gre.c
-)
-
-list(APPEND VNET_HEADERS
- ipsec-gre/ipsec_gre.h
- ipsec-gre/error.def
-)
-
-list(APPEND VNET_API_FILES ipsec-gre/ipsec_gre.api)
-
-##############################################################################
# LISP control plane: lisp-cp
##############################################################################