aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <neale@graphiant.com>2021-08-10 07:39:18 +0000
committerOle Tr�an <otroan@employees.org>2021-08-11 08:48:42 +0000
commitd6953332db225d5355f50348ef3b09f0525d5282 (patch)
tree3f4870c12c97f458119d6460e4082de767181c2b /src/vnet/CMakeLists.txt
parent7244a706430746facf20a5f047666b74d440cef8 (diff)
fib: A 16-8-8 and a 8-8-8-8 versions of an ip4_fib_t
Type: feature The difference being the MTRIE type they contain. THE FIB continues to use the 16-8-8 version. Signed-off-by: Neale Ranns <neale@graphiant.com> Change-Id: I5a54d4e6e6cc639f18a3fb65ef2925507a7ef1de
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index a800230c9d5..df23738013d 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -1164,7 +1164,10 @@ list(APPEND VNET_HEADERS
list(APPEND VNET_SOURCES
fib/fib.c
+ fib/ip4_fib_hash.c
fib/ip4_fib.c
+ fib/ip4_fib_16.c
+ fib/ip4_fib_8.c
fib/ip6_fib.c
fib/mpls_fib.c
fib/fib_table.c