aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorPrashant Maheshwari <pmahesh2@cisco.com>2019-11-14 12:42:59 +0530
committerNeale Ranns <nranns@cisco.com>2019-12-03 05:45:27 +0000
commitdbf68c9aa258238260df34c0e864223ea4f3a987 (patch)
tree545f58115df3ef1570ea526675401018cf59ccea /src/vnet/CMakeLists.txt
parentabde62fb83ebd0e0e1204fc77affe909fc95ba51 (diff)
ipsec: Changes to make ipsec encoder/decoders reusable by the plugins
Type: fix Signed-off-by: Prashant Maheshwari <pmahesh2@cisco.com> Change-Id: I81b937fc8cfec36f8fb5de711ffbb02f23f3664e Signed-off-by: Prashant Maheshwari <pmahesh2@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 8afbc1cec13..18898e152d1 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -584,6 +584,7 @@ list(APPEND VNET_SOURCES
ipsec/ah_decrypt.c
ipsec/ah_encrypt.c
ipsec/ipsec_api.c
+ ipsec/ipsec_types_api.c
)
list(APPEND VNET_MULTIARCH_SOURCES
@@ -596,6 +597,7 @@ list(APPEND VNET_MULTIARCH_SOURCES
ipsec/ipsec_tun_in.c
)
+list(APPEND VNET_API_FILES ipsec/ipsec_types.api)
list(APPEND VNET_API_FILES ipsec/ipsec.api)
list(APPEND VNET_SOURCES
@@ -608,6 +610,7 @@ list(APPEND VNET_HEADERS
ipsec/ipsec_spd_policy.h
ipsec/ipsec_sa.h
ipsec/ipsec_tun.h
+ ipsec/ipsec_types_api.h
ipsec/ipsec_punt.h
ipsec/esp.h
ipsec/ah.h