aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorKlement Sekera <ksekera@cisco.com>2019-06-25 11:19:22 +0000
committerOle Trøan <otroan@employees.org>2019-09-26 14:12:07 +0000
commitde34c35fc73226943538149fae9dbc5cfbdc6e75 (patch)
treeab354210305403bc29a3effc7c002f947422cb9f /src/vnet/CMakeLists.txt
parent33538a15087eea7c994b6f3d8a952c4b6ea98ee4 (diff)
ip: add shallow virtual reassembly functionality
Type: feature Change-Id: Ibc8334e26c7e6f6120696c3e313b6e11d73dab99 Signed-off-by: Klement Sekera <ksekera@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index aaa16d8389b..6ce383350bf 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -432,6 +432,7 @@ list(APPEND VNET_SOURCES
ip/ip4_source_and_port_range_check.c
ip/ip4_source_check.c
ip/reass/ip4_full_reass.c
+ ip/reass/ip4_sv_reass.c
ip/ip6_format.c
ip/ip6_forward.c
ip/ip6_ll_table.c
@@ -442,6 +443,7 @@ list(APPEND VNET_SOURCES
ip/ip6_neighbor.c
ip/ip6_pg.c
ip/reass/ip6_full_reass.c
+ ip/reass/ip6_sv_reass.c
ip/rd_cp.c
ip/ip_neighbor.c
ip/ip_api.c
@@ -464,6 +466,10 @@ list(APPEND VNET_MULTIARCH_SOURCES
ip/reass/ip4_full_reass.c
ip/ip6_hop_by_hop.c
ip/reass/ip6_full_reass.c
+ ip/reass/ip4_sv_reass.c
+ ip/ip6_hop_by_hop.c
+ ip/reass/ip6_full_reass.c
+ ip/reass/ip6_sv_reass.c
ip/ip6_input.c
ip/ip6_punt_drop.c
ip/punt_node.c