aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-11-12 17:16:47 +0000
committerFlorin Coras <florin.coras@gmail.com>2019-11-12 18:56:04 +0000
commitea93e48cf6e918937422638cb574964b88a146b6 (patch)
treec35f8c921a8a9175b0dbf89e3e0775abc433e521 /src/vnet/CMakeLists.txt
parentc046d709e1e493d20fee80f8c23b4106be67a98e (diff)
ip: IP address and prefix types (moved from LISP)
Type: refactor Change-Id: I2c6b59013bfd21136a2955442c779685f951932b Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index b4ea14e9762..620af8f5fd2 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -453,6 +453,7 @@ list(APPEND VNET_SOURCES
ip/ip_init.c
ip/ip_in_out_acl.c
ip/ip_punt_drop.c
+ ip/ip_types.c
ip/lookup.c
ip/punt_api.c
ip/punt.c
@@ -495,6 +496,7 @@ list(APPEND VNET_HEADERS
ip/ip_packet.h
ip/ip_source_and_port_range_check.h
ip/ip_neighbor.h
+ ip/ip_types.h
ip/lookup.h
ip/ports.def
ip/protocols.def