aboutsummaryrefslogtreecommitdiffstats
path: root/src/vpp-api/python/setup.py
diff options
context:
space:
mode:
authorOle Trøan <otroan@employees.org>2018-06-18 18:30:09 +0000
committerOle Trøan <otroan@employees.org>2018-06-18 18:30:09 +0000
commit61debaaaf2230c75d2435a6c866293e2d6359c44 (patch)
treef39dcd6ddc1ba13eeb08d29de8530dde8999ce2a /src/vpp-api/python/setup.py
parenta5ee900fb75201bbfceaf13c8bc57a13ed094988 (diff)
Revert "Python API: Add enum and union support."
This reverts commit a5ee900fb75201bbfceaf13c8bc57a13ed094988. Some of the unit tests breaks. Backing out until fixed. Change-Id: I1846fb417db44a2a772f7b59cda8bcfe6d39f8c3 Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'src/vpp-api/python/setup.py')
-rw-r--r--src/vpp-api/python/setup.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/vpp-api/python/setup.py b/src/vpp-api/python/setup.py
index 20b9901d521..abda43de606 100644
--- a/src/vpp-api/python/setup.py
+++ b/src/vpp-api/python/setup.py
@@ -13,20 +13,21 @@
# limitations under the License.
try:
- from setuptools import setup, find_packages
+ from setuptools import setup
except ImportError:
- from distutils.core import setup, find_packages
+ from distutils.core import setup
setup (name = 'vpp_papi',
- version = '1.5',
+ version = '1.4',
description = 'VPP Python binding',
author = 'Ole Troan',
author_email = 'ot@cisco.com',
url = 'https://wiki.fd.io/view/VPP/Python_API',
+ python_requires='>=2.7, >=3.3',
license = 'Apache-2.0',
test_suite = 'tests',
- install_requires=['cffi >= 1.6', 'enum34'],
- packages=find_packages(),
+ install_requires=['cffi >= 1.6'],
+ py_modules=['vpp_papi'],
long_description = '''VPP Python language binding.''',
zip_safe = True,
)