aboutsummaryrefslogtreecommitdiffstats
path: root/src/vppinfra/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2020-02-11 15:06:34 -0500
committerFlorin Coras <florin.coras@gmail.com>2020-02-11 23:57:18 +0000
commit2c8e0023f91882e53f06eb99c901b97fe013f981 (patch)
treea0026aa039284780b7ec5da6f913e9cab5edd489 /src/vppinfra/CMakeLists.txt
parenta6ef36b2c25de47824a1b45e147ab2fbf67c3a33 (diff)
vppinfra: remove the historical mheap memory allocator
The mheap allocator has been turned off for several releases. This commit removes the cmake config parameter, parallel support for dlmalloc and mheap, and the mheap allocator itself. Type: refactor Signed-off-by: Dave Barach <dave@barachs.net> Change-Id: I104f88a1f06e47e90e5f7fb3e11cd1ca66467903
Diffstat (limited to 'src/vppinfra/CMakeLists.txt')
-rw-r--r--src/vppinfra/CMakeLists.txt30
1 files changed, 6 insertions, 24 deletions
diff --git a/src/vppinfra/CMakeLists.txt b/src/vppinfra/CMakeLists.txt
index 1c234cce234..3998ae6f6a6 100644
--- a/src/vppinfra/CMakeLists.txt
+++ b/src/vppinfra/CMakeLists.txt
@@ -17,12 +17,6 @@ enable_language(ASM)
# Generate vppinfra/config.h
##############################################################################
set(LOG2_CACHE_LINE_BYTES ${VPP_LOG2_CACHE_LINE_SIZE})
-option(VPP_USE_DLMALLOC "Use dlmalloc memory allocator." ON)
-if(VPP_USE_DLMALLOC)
- set(DLMALLOC 1)
-else(VPP_USE_DLMALLOC)
- set(DLMALLOC 0)
-endif(VPP_USE_DLMALLOC)
configure_file(
${CMAKE_SOURCE_DIR}/vppinfra/config.h.in
@@ -43,6 +37,7 @@ set(VPPINFRA_SRCS
bihash_all_vector.c
cpu.c
cuckoo_template.c
+ dlmalloc.c
elf.c
elog.c
error.c
@@ -55,14 +50,15 @@ set(VPPINFRA_SRCS
longjmp.S
macros.c
maplog.c
+ mem_dlmalloc.c
mhash.c
mpcap.c
pcap.c
pmalloc.c
pool.c
ptclosure.c
- random.c
random_buffer.c
+ random.c
random_isaac.c
rbtree.c
serialize.c
@@ -73,11 +69,11 @@ set(VPPINFRA_SRCS
time.c
time_range.c
timing_wheel.c
- tw_timer_2t_1w_2048sl.c
- tw_timer_16t_2w_512sl.c
tw_timer_16t_1w_2048sl.c
- tw_timer_4t_3w_256sl.c
+ tw_timer_16t_2w_512sl.c
tw_timer_1t_3w_1024sl_ov.c
+ tw_timer_2t_1w_2048sl.c
+ tw_timer_4t_3w_256sl.c
unformat.c
unix-formats.c
unix-misc.c
@@ -135,7 +131,6 @@ set(VPPINFRA_HEADERS
memcpy_sse3.h
mem.h
mhash.h
- mheap_bootstrap.h
mheap.h
mpcap.h
os.h
@@ -195,19 +190,6 @@ if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
)
endif()
-
-if(VPP_USE_DLMALLOC)
- list(APPEND VPPINFRA_SRCS
- dlmalloc.c
- mem_dlmalloc.c
- )
-else(VPP_USE_DLMALLOC)
- list(APPEND VPPINFRA_SRCS
- mheap.c
- mem_mheap.c
- )
-endif(VPP_USE_DLMALLOC)
-
add_vpp_library(vppinfra
SOURCES ${VPPINFRA_SRCS}
LINK_LIBRARIES m