aboutsummaryrefslogtreecommitdiffstats
path: root/src/vppinfra/CMakeLists.txt
diff options
context:
space:
mode:
authorNathan Moos <nmoos@cisco.com>2021-01-15 15:50:59 -0800
committerDamjan Marion <dmarion@me.com>2021-01-20 15:23:06 +0000
commit67d7acd059572c1eb08b86f66ec75de3d2bde365 (patch)
tree4b394b56cd9275dae309f616358a5483e069577e /src/vppinfra/CMakeLists.txt
parentcf5ba26700845b3956beb71314875fa192f5b711 (diff)
vppinfra: add option to use libexecinfo
Type: feature The musl libc does not provide <execinfo.h> or an implementation of the functions provided. This patch enables the use of libexecinfo as an alternative, which can be used on systems with musl. Change-Id: I76b5744ddf731b66e16144025a6fdedf72925260 Signed-off-by: Nathan Moos <nmoos@cisco.com>
Diffstat (limited to 'src/vppinfra/CMakeLists.txt')
-rw-r--r--src/vppinfra/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/vppinfra/CMakeLists.txt b/src/vppinfra/CMakeLists.txt
index 07fc1095c6b..8ec843ad2ca 100644
--- a/src/vppinfra/CMakeLists.txt
+++ b/src/vppinfra/CMakeLists.txt
@@ -200,9 +200,13 @@ if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
)
endif()
+option(VPP_USE_EXTERNAL_LIBEXECINFO "Use external libexecinfo (useful for non-glibc targets)." OFF)
+if(VPP_USE_EXTERNAL_LIBEXECINFO)
+ set(EXECINFO_LIB execinfo)
+endif()
add_vpp_library(vppinfra
SOURCES ${VPPINFRA_SRCS}
- LINK_LIBRARIES m
+ LINK_LIBRARIES m ${EXECINFO_LIB}
INSTALL_HEADERS ${VPPINFRA_HEADERS}
COMPONENT libvppinfra
LTO