aboutsummaryrefslogtreecommitdiffstats
path: root/src/vppinfra/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Grishenko <themiron@yandex-team.ru>2022-09-28 13:37:02 +0500
committerDave Barach <vpp@barachs.net>2023-03-19 12:17:23 +0000
commit8a4b79778f8b3149d663face83d37fbf96e12d05 (patch)
tree28a77bedaa359eecc075417cdc631dbedc7368b9 /src/vppinfra/CMakeLists.txt
parentb9c8c57e983246ec034bc9059b1740558c951d51 (diff)
vppinfra: fix pool free bitmap allocation
Using clib_bitmap_vec_validate makes free bitmap vector to be x64 times bigger (assuming x86_64) than necessary when non-zero and possible oom due (u32)(0 - 1) math with zero alloc. Fix it with clib_bitmap_validate which takes bit size, not index and ensure at least one bit is allocated. Type: fix Change-Id: I7e191f4e2fb3722a06bb800e1d075f7c7e2dcec9 Signed-off-by: Vladislav Grishenko <themiron@yandex-team.ru>
Diffstat (limited to 'src/vppinfra/CMakeLists.txt')
-rw-r--r--src/vppinfra/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vppinfra/CMakeLists.txt b/src/vppinfra/CMakeLists.txt
index e24e0493ca9..204858d30a8 100644
--- a/src/vppinfra/CMakeLists.txt
+++ b/src/vppinfra/CMakeLists.txt
@@ -247,6 +247,7 @@ if(VPP_BUILD_VPPINFRA_TESTS)
macros
maplog
pmalloc
+ pool_alloc
pool_iterate
ptclosure
random