aboutsummaryrefslogtreecommitdiffstats
path: root/src/vppinfra/CMakeLists.txt
diff options
context:
space:
mode:
authorTianyu Li <tianyu.li@arm.com>2023-03-21 06:49:38 +0000
committerTianyu Li <tianyu.li@arm.com>2023-03-22 15:05:45 +0800
commitb53b88a08ef25031708d1e51960713845752c6f2 (patch)
tree8804f838b9d5afcf457351a2cbeb6f1f837924a9 /src/vppinfra/CMakeLists.txt
parent653ef7355c05145485f49ce7e34eea043d389bba (diff)
build: fix rpm build error with test_infra
RPM build errors: error: Installed (but unpackaged) file(s) found: /usr/bin/test_infra Add NO_INSTALL tag in CMakeLists to avoid installing test binary. Type: fix Fixes: c3542e17b5df ("vppinfra: widen the scope of test_vector_funcs") Signed-off-by: Tianyu Li <tianyu.li@arm.com> Change-Id: I359ba79af2e3cb32b47dda3bb8707a5d2fd8586b
Diffstat (limited to 'src/vppinfra/CMakeLists.txt')
-rw-r--r--src/vppinfra/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/vppinfra/CMakeLists.txt b/src/vppinfra/CMakeLists.txt
index 204858d30a8..4a9c008b65e 100644
--- a/src/vppinfra/CMakeLists.txt
+++ b/src/vppinfra/CMakeLists.txt
@@ -294,6 +294,7 @@ add_vpp_executable(test_infra
test/test.c
${test_files}
LINK_LIBRARIES vppinfra
+ NO_INSTALL
)
vpp_library_set_multiarch_sources(test_infra