aboutsummaryrefslogtreecommitdiffstats
path: root/src/vppinfra/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2023-03-15 11:42:06 +0000
committerFlorin Coras <florin.coras@gmail.com>2023-03-15 17:07:01 +0000
commitc3542e17b5dfea27f46f0656e8f1f8092545b796 (patch)
tree623b16012e5b19484781245e1532024b1669fa2b /src/vppinfra/CMakeLists.txt
parentadeaf16960f8895eb246b388553a49d2ade80dc4 (diff)
vppinfra: widen the scope of test_vector_funcs
Location changed and binary renamed to test_infra Also it is built by default. Type: improvement Change-Id: I27cd97f274501ceb7a01213e2bc9676cea00f39c Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/vppinfra/CMakeLists.txt')
-rw-r--r--src/vppinfra/CMakeLists.txt26
1 files changed, 13 insertions, 13 deletions
diff --git a/src/vppinfra/CMakeLists.txt b/src/vppinfra/CMakeLists.txt
index d7445b0982f..40951336387 100644
--- a/src/vppinfra/CMakeLists.txt
+++ b/src/vppinfra/CMakeLists.txt
@@ -273,29 +273,29 @@ if(VPP_BUILD_VPPINFRA_TESTS)
LINK_LIBRARIES vppinfra Threads::Threads
)
endforeach()
+endif(VPP_BUILD_VPPINFRA_TESTS)
set(test_files
- vector/test/array_mask.c
- vector/test/compress.c
- vector/test/count_equal.c
- vector/test/index_to_ptr.c
- vector/test/ip_csum.c
- vector/test/mask_compare.c
- vector/test/memcpy_x86_64.c
- vector/test/sha2.c
- vector/test/toeplitz.c
+ test/array_mask.c
+ test/compress.c
+ test/count_equal.c
+ test/index_to_ptr.c
+ test/ip_csum.c
+ test/mask_compare.c
+ test/memcpy_x86_64.c
+ test/sha2.c
+ test/toeplitz.c
)
-add_vpp_executable(test_vector_funcs
+add_vpp_executable(test_infra
SOURCES
- vector/test/test.c
+ test/test.c
${test_files}
LINK_LIBRARIES vppinfra
)
-vpp_library_set_multiarch_sources(test_vector_funcs
+vpp_library_set_multiarch_sources(test_infra
SOURCES
${test_files}
)
-endif(VPP_BUILD_VPPINFRA_TESTS)