aboutsummaryrefslogtreecommitdiffstats
path: root/src/vppinfra/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2021-07-13 21:12:41 +0200
committerFlorin Coras <florin.coras@gmail.com>2021-07-13 20:06:19 +0000
commitd154a17989b1da7abbfdb87b98b90cc5f4d3295f (patch)
tree9353de897ec10d0afd3005dd2cf26e0b7ac512ef /src/vppinfra/CMakeLists.txt
parentb7e4d4487c0fa02f3869d24799c6573452276396 (diff)
vppinfra: put each vector function into own file
Type: refactor Change-Id: I2dd9a18497992ac7e2686c14f5d17eccccda0cda Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/vppinfra/CMakeLists.txt')
-rw-r--r--src/vppinfra/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/vppinfra/CMakeLists.txt b/src/vppinfra/CMakeLists.txt
index 64420b96676..8f9d0746b42 100644
--- a/src/vppinfra/CMakeLists.txt
+++ b/src/vppinfra/CMakeLists.txt
@@ -188,7 +188,8 @@ set(VPPINFRA_HEADERS
vector_altivec.h
vector_avx2.h
vector_avx512.h
- vector_funcs.h
+ vector/mask_compare.h
+ vector/compress.h
vector.h
vector_neon.h
vector_sse42.h
@@ -264,13 +265,13 @@ if(VPP_BUILD_VPPINFRA_TESTS)
endforeach()
set(test_files
- test_vector_funcs_compress.c
- test_vector_funcs_mask_compare.c
+ vector/test/compress.c
+ vector/test/mask_compare.c
)
add_vpp_executable(test_vector_funcs
SOURCES
- test_vector_funcs.c
+ vector/test/test.c
${test_files}
LINK_LIBRARIES vppinfra
)