aboutsummaryrefslogtreecommitdiffstats
path: root/src/vppinfra/CMakeLists.txt
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2020-11-18 19:17:48 +0100
committerNeale Ranns <nranns@cisco.com>2020-11-25 08:25:50 +0000
commitdf87f8092f5b6b54eef0d5acf3c27c2e398a401a (patch)
tree762a3da5d6757c6f475ffce6dcfae2b65b2c3850 /src/vppinfra/CMakeLists.txt
parentc95cfa218b214bd1c67dc165b4ed1fb7a224bdad (diff)
api: vat2 and json autogeneration for api messages
VAT2: A completely auto-generated replacement of VAT. Reads input message in JSON from stdin and outputs received messages in JSON. A VAT2 plugin is automatically built for a .api file. There no longer a need for a separate _test.c. Example: vat2 show_version {} { "_msgname": "show_version_reply", "retval": 0, "program": "vpe", "version": "21.01-rc0~411-gf6eb348a6", "build_date": "2020-11-19T09:49:25", "build_directory": "/vpp/autogen3" } vat2 sw_interface_dump '{"sw_if_index": -1, "name_filter_valid": 0, "name_filter": ""}' [{ "_msgname": "sw_interface_details", "sw_if_index": 0, "sup_sw_if_index": 0, "l2_address": "00:00:00:00:00:00", "flags": "Invalid ENUM", "type": "IF_API_TYPE_HARDWARE", "link_duplex": "LINK_DUPLEX_API_UNKNOWN", "link_speed": 0, "link_mtu": 0, "mtu": [0, 0, 0, 0], "sub_id": 0, "sub_number_of_tags": 0, "sub_outer_vlan_id": 0, "sub_inner_vlan_id": 0, "sub_if_flags": "Invalid ENUM", "vtr_op": 0, "vtr_push_dot1q": 0, "vtr_tag1": 0, "vtr_tag2": 0, "outer_tag": 0, "b_dmac": "00:00:00:00:00:00", "b_smac": "00:00:00:00:00:00", "b_vlanid": 0, "i_sid": 0, "interface_name": "local0", "interface_dev_type": "local", "tag": "" }] This is the first phase and vat2 is not integrated in packaging yet. Type: feature Signed-off-by: Ole Troan <ot@cisco.com> Change-Id: Ib45ddeafb180ea7da8c5dc274a9274d7a4edc876 Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'src/vppinfra/CMakeLists.txt')
-rw-r--r--src/vppinfra/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/vppinfra/CMakeLists.txt b/src/vppinfra/CMakeLists.txt
index a670181732e..a972d906769 100644
--- a/src/vppinfra/CMakeLists.txt
+++ b/src/vppinfra/CMakeLists.txt
@@ -38,6 +38,11 @@ install(
add_definitions(-fvisibility=hidden)
+# Ensure symbols from cJSON are exported
+set_source_files_properties( cJSON.c PROPERTIES
+ COMPILE_DEFINITIONS " CJSON_API_VISIBILITY " )
+
+
##############################################################################
# vppinfra sources
##############################################################################
@@ -88,6 +93,7 @@ set(VPPINFRA_SRCS
valloc.c
vec.c
vector.c
+ cJSON.c
)
set(VPPINFRA_HEADERS
@@ -108,6 +114,7 @@ set(VPPINFRA_HEADERS
cache.h
callback.h
callback_data.h
+ cJSON.h
clib_error.h
clib.h
cpu.h