aboutsummaryrefslogtreecommitdiffstats
path: root/src/vppinfra/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Jones <thj@freebsd.org>2024-01-26 17:04:23 +0000
committerDamjan Marion <dmarion@0xa5.net>2024-02-18 16:00:09 +0000
commite12f69f7731d4bbb923b7d263179a9d530ce09db (patch)
treedcbe98a4d359b35ba4e8582886848bf158f1793b /src/vppinfra/CMakeLists.txt
parent2cbbbb6d158e4463e64d638f92368d0076840438 (diff)
vppinfra: Provide FreeBSD implementation of clib_mem functions
Working from the implementation in linux/mem.c add FreeBSD specific functionality. This duplicates parts of the Linux implementation and a depuplication job could be run in the future. Stub out some parts of the API for now, they are either use unavailable features on FreeBSD or require further implementation than this initial implementation. Type: improvement Change-Id: I1e443e32304d19776a9a4d5e34adfa16ec919427 Signed-off-by: Tom Jones <thj@freebsd.org>
Diffstat (limited to 'src/vppinfra/CMakeLists.txt')
-rw-r--r--src/vppinfra/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/vppinfra/CMakeLists.txt b/src/vppinfra/CMakeLists.txt
index 86b1c884269..f34ceed9d15 100644
--- a/src/vppinfra/CMakeLists.txt
+++ b/src/vppinfra/CMakeLists.txt
@@ -222,6 +222,11 @@ if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
perfmon/bundle_core_power.c
perfmon/perfmon.c
)
+elseif("${CMAKE_SYSTEM_NAME}" STREQUAL "FreeBSD")
+ list(APPEND VPPINFRA_SRCS
+ elf_clib.c
+ freebsd/mem.c
+ )
endif()
option(VPP_USE_EXTERNAL_LIBEXECINFO "Use external libexecinfo (useful for non-glibc targets)." OFF)