aboutsummaryrefslogtreecommitdiffstats
path: root/src/vppinfra/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2021-05-06 17:34:49 +0200
committerDamjan Marion <dmarion@me.com>2021-05-07 05:09:27 +0000
commite3e355507508ccbe1a14b78e0654775af8d932fe (patch)
treeebe9c5c8f74cb542da311587de7f35a8be0e8ab3 /src/vppinfra/CMakeLists.txt
parentcec1b2776b4b6967d400bc86551765ac7fa4643e (diff)
vppinfra: add universal array mask_compare and compress funcs
Type: improvement Change-Id: I6d812339f626ea630ad9354632d2f9506122d379 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/vppinfra/CMakeLists.txt')
-rw-r--r--src/vppinfra/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/vppinfra/CMakeLists.txt b/src/vppinfra/CMakeLists.txt
index dd3690bdbf3..6da1fa2a0a1 100644
--- a/src/vppinfra/CMakeLists.txt
+++ b/src/vppinfra/CMakeLists.txt
@@ -261,4 +261,22 @@ if(VPP_BUILD_VPPINFRA_TESTS)
LINK_LIBRARIES vppinfra Threads::Threads
)
endforeach()
+
+set(test_files
+ test_vector_funcs_compress.c
+ test_vector_funcs_mask_compare.c
+)
+
+add_vpp_executable(test_vector_funcs
+ SOURCES
+ test_vector_funcs.c
+ ${test_files}
+ LINK_LIBRARIES vppinfra
+)
+
+vpp_library_set_multiarch_sources(test_vector_funcs
+ SOURCES
+ ${test_files}
+)
+
endif(VPP_BUILD_VPPINFRA_TESTS)