aboutsummaryrefslogtreecommitdiffstats
path: root/svm/Makefile.am
diff options
context:
space:
mode:
authorEd Warnicke <eaw@cisco.com>2015-12-08 15:45:58 -0700
committerEd Warnicke <eaw@cisco.com>2015-12-08 15:47:27 -0700
commitcb9cadad578297ffd78fa8a33670bdf1ab669e7e (patch)
tree6ac2be912482cc7849a26f0ab845561c3d7f4e26 /svm/Makefile.am
parentfb0815d4ae4bb0fe27bd9313f34b45c8593b907e (diff)
Initial commit of vpp code.v1.0.0
Change-Id: Ib246f1fbfce93274020ee93ce461e3d8bd8b9f17 Signed-off-by: Ed Warnicke <eaw@cisco.com>
Diffstat (limited to 'svm/Makefile.am')
-rw-r--r--svm/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/svm/Makefile.am b/svm/Makefile.am
new file mode 100644
index 00000000000..490e27b33a6
--- /dev/null
+++ b/svm/Makefile.am
@@ -0,0 +1,30 @@
+# Copyright (c) 2015 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS = svmtool svmdbtool
+
+AM_CFLAGS = -Wall
+
+nobase_include_HEADERS = svm.h ssvm.h svmdb.h
+
+lib_LTLIBRARIES = libsvm.la libsvmdb.la
+
+libsvm_la_SOURCES = svm.c ssvm.c
+
+svmtool_LDADD = libsvm.la -lvppinfra -lpthread -lrt
+
+libsvmdb_la_SOURCES = svmdb.c
+
+svmdbtool_LDADD = libsvmdb.la libsvm.la -lvppinfra -lpthread -lrt