summaryrefslogtreecommitdiffstats
path: root/vlib/configure.ac
diff options
context:
space:
mode:
authorEd Warnicke <eaw@cisco.com>2015-12-08 15:45:58 -0700
committerEd Warnicke <eaw@cisco.com>2015-12-08 15:47:27 -0700
commitcb9cadad578297ffd78fa8a33670bdf1ab669e7e (patch)
tree6ac2be912482cc7849a26f0ab845561c3d7f4e26 /vlib/configure.ac
parentfb0815d4ae4bb0fe27bd9313f34b45c8593b907e (diff)
Initial commit of vpp code.v1.0.0
Change-Id: Ib246f1fbfce93274020ee93ce461e3d8bd8b9f17 Signed-off-by: Ed Warnicke <eaw@cisco.com>
Diffstat (limited to 'vlib/configure.ac')
-rw-r--r--vlib/configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/vlib/configure.ac b/vlib/configure.ac
new file mode 100644
index 00000000000..4fdcff12aaa
--- /dev/null
+++ b/vlib/configure.ac
@@ -0,0 +1,26 @@
+AC_INIT(vlib, 1.1)
+AM_INIT_AUTOMAKE
+AM_SILENT_RULES
+
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_PROG_LIBTOOL
+
+AC_ARG_WITH(dpdk,
+ AC_HELP_STRING([--with-dpdk],[Use the Intel dpdk]),
+ [with_dpdk=1],
+ [with_dpdk=0])
+
+AC_ARG_WITH(pre-data,
+ AC_HELP_STRING([--with-pre-data],[Set buffer rewrite space]),
+ [case $with_pre_data in
+ 128) ;;
+ 256) ;;
+ *) with_pre_data="pre-data-not-set" ;;
+ esac], [with_pre_data=128])
+
+AM_CONDITIONAL(WITH_DPDK, test "$with_dpdk" = "1")
+AC_SUBST(DPDK,[-DDPDK=${with_dpdk}])
+AC_SUBST(PRE_DATA_SIZE,[$with_pre_data])
+
+AC_OUTPUT([Makefile])