aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorPavel Kotucek <pkotucek@cisco.com>2016-12-20 08:13:14 +0100
committerDamjan Marion <damarion@cisco.com>2016-12-21 23:45:36 +0100
commit1099b0db45a7a0bb597c4deb5b9387f5b6ae280f (patch)
treea2759a9987595b56c3174c9f3eb83c0515c92857 /vnet/Makefile.am
parent296b20162affd0b3bb4168ced045fe7bcb15b03b (diff)
API refactoring : gre
Change-Id: Idea10d6ba4139fdcb4f16300a06c2b30ef339b3c Signed-off-by: Pavel Kotucek <pkotucek@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index a4031824e39..4425171b9fb 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -22,6 +22,8 @@ BUILT_SOURCES = \
vnet/devices/netmap/netmap.api.json \
vnet/devices/virtio/vhost_user.api.h \
vnet/devices/virtio/vhost_user.api.json \
+ vnet/gre/gre.api.h \
+ vnet/gre/gre.api.json \
vnet/interface.api.h \
vnet/interface.api.json \
vnet/ip/ip.api.h \
@@ -469,12 +471,14 @@ libvnet_la_SOURCES += \
vnet/gre/gre.c \
vnet/gre/node.c \
vnet/gre/interface.c \
- vnet/gre/pg.c
+ vnet/gre/pg.c \
+ vnet/gre/gre_api.c
nobase_include_HEADERS += \
vnet/gre/gre.h \
vnet/gre/packet.h \
- vnet/gre/error.def
+ vnet/gre/error.def \
+ vnet/gre/gre.api.h
########################################
# Tunnel protocol: l2tpv3
@@ -956,6 +960,7 @@ api_DATA = \
vnet/devices/af_packet/af_packet.api.json \
vnet/devices/netmap/netmap.api.json \
vnet/devices/virtio/vhost_user.api.json \
+ vnet/gre/gre.api.json \
vnet/interface.api.json \
vnet/ip/ip.api.json \
vnet/l2/l2.api.json \