aboutsummaryrefslogtreecommitdiffstats
path: root/vpp-api-test/configure.ac
diff options
context:
space:
mode:
authorEd Warnicke <eaw@cisco.com>2015-12-08 15:45:58 -0700
committerEd Warnicke <eaw@cisco.com>2015-12-08 15:47:27 -0700
commitcb9cadad578297ffd78fa8a33670bdf1ab669e7e (patch)
tree6ac2be912482cc7849a26f0ab845561c3d7f4e26 /vpp-api-test/configure.ac
parentfb0815d4ae4bb0fe27bd9313f34b45c8593b907e (diff)
Initial commit of vpp code.v1.0.0
Change-Id: Ib246f1fbfce93274020ee93ce461e3d8bd8b9f17 Signed-off-by: Ed Warnicke <eaw@cisco.com>
Diffstat (limited to 'vpp-api-test/configure.ac')
-rw-r--r--vpp-api-test/configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/vpp-api-test/configure.ac b/vpp-api-test/configure.ac
new file mode 100644
index 00000000000..652ddb5f674
--- /dev/null
+++ b/vpp-api-test/configure.ac
@@ -0,0 +1,33 @@
+AC_INIT(vpe-api-test, 1.0)
+AM_INIT_AUTOMAKE
+
+AC_PROG_LIBTOOL
+AM_PROG_AS
+AC_PROG_CC
+AM_PROG_CC_C_O
+
+AC_ARG_WITH(q-plugin-prefix,
+ AC_HELP_STRING([--with-q-plugin-prefix],[vlib plugin prefix]),
+ [case $with_q_plugin_prefix in
+ *) ;;
+ esac])
+
+AC_ARG_WITH(q-platform,
+ AC_HELP_STRING([--with-q-platform],[Build version for given platform (qnative)]),
+ [case $with_q_platform in
+ qnative) ;;
+ vpe) with_q_platform=vpe;;
+ *) with_q_platform=qnative;;
+ esac])
+
+AC_ARG_WITH(dpdk,
+ AC_HELP_STRING([--with-dpdk],[Use the Intel dpdk]),
+ [with_dpdk=1],
+ [with_dpdk=0])
+
+AC_SUBST(Q_PLATFORM_DEFINE,[-DQ_PLATFORM_${with_q_platform}])
+AC_SUBST(Q_PLATFORM_PLUGPATH,[-DQ_PLUGIN_PREFIX=${with_q_plugin_prefix}])
+AC_SUBST(DPDK,[-DDPDK=${with_dpdk}])
+AM_CONDITIONAL(WITH_DPDK, test "$with_dpdk" = "1")
+
+AC_OUTPUT([Makefile])