aboutsummaryrefslogtreecommitdiffstats
path: root/vpp-api/java/Makefile.am
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2016-04-09 03:16:30 +0200
committerDave Wallace <dwallacelf@gmail.com>2016-04-20 16:50:29 +0000
commit6855f6cdfee8c479f1e0ae440ce87a91ff41a708 (patch)
treee438e21c8107a675dc3a3141c6af6ba0ab458992 /vpp-api/java/Makefile.am
parent633951c3d8dc1640813b4778f3e35463d08f3795 (diff)
Python-API: Inital commit of Python bindings for the VPP API.
See: https://wiki.fd.io/view/VPP/Python_API Change-Id: If135fc32208c7031787e1935b399d930e0e1ea1f Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'vpp-api/java/Makefile.am')
-rw-r--r--vpp-api/java/Makefile.am93
1 files changed, 93 insertions, 0 deletions
diff --git a/vpp-api/java/Makefile.am b/vpp-api/java/Makefile.am
new file mode 100644
index 00000000000..0e16b72b38f
--- /dev/null
+++ b/vpp-api/java/Makefile.am
@@ -0,0 +1,93 @@
+# Copyright (c) 2015 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign subdir-objects
+ACLOCAL_AMFLAGS = -I m4
+AM_CFLAGS = -Wall
+
+noinst_PROGRAMS =
+BUILT_SOURCES =
+bin_PROGRAMS =
+CLEANFILES =
+lib_LTLIBRARIES =
+
+nobase_include_HEADERS = \
+ japi/org_openvpp_vppjapi_vppApi.h \
+ japi/org_openvpp_vppjapi_vppConn.h
+
+lib_LTLIBRARIES += libvppjni.la
+
+libvppjni_la_SOURCES = japi/vppjni.c japi/vppapi.c japi/vppjni_env.h japi/vppjni_env.c
+libvppjni_la_LIBADD = -lvlibmemoryclient -lvlibapi -lsvm -lvppinfra \
+ -lpthread -lm -lrt
+libvppjni_la_LDFLAGS = -module
+libvppjni_la_CPPFLAGS = -I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux
+
+jarfile = vppjapi-$(PACKAGE_VERSION).jar
+packagedir = org/openvpp/vppjapi
+JAVAROOT = .
+
+$(jarfile): libvppjni.la
+ cd .libs ; $(JAR) cf $(JARFLAGS) ../$@ libvppjni.so.0.0.0 ../$(packagedir)/*.class ; cd ..
+
+BUILT_SOURCES += japi/org_openvpp_vppjapi_vppConn.h japi/vppapi.c
+
+japi/org_openvpp_vppjapi_vppConn.h: \
+ japi/org/openvpp/vppjapi/vppVersion.java \
+ japi/org/openvpp/vppjapi/vppInterfaceDetails.java \
+ japi/org/openvpp/vppjapi/vppInterfaceCounters.java \
+ japi/org/openvpp/vppjapi/vppBridgeDomainDetails.java \
+ japi/org/openvpp/vppjapi/vppBridgeDomainInterfaceDetails.java \
+ japi/org/openvpp/vppjapi/vppL2Fib.java \
+ japi/org/openvpp/vppjapi/vppIPv4Address.java \
+ japi/org/openvpp/vppjapi/vppIPv6Address.java \
+ japi/org/openvpp/vppjapi/vppVxlanTunnelDetails.java \
+ japi/org/openvpp/vppjapi/vppConn.java \
+ japi/org/openvpp/vppjapi/vppApiCallbacks.java \
+ ../../vpp/api/vpe.api.h
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppVersion.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppVersion ; \
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppInterfaceDetails.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppInterfaceDetails ; \
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppInterfaceCounters.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppInterfaceCounters ; \
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppBridgeDomainInterfaceDetails.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppBridgeDomainInterfaceDetails ; \
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppBridgeDomainDetails.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppBridgeDomainDetails ; \
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppL2Fib.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppL2Fib ; \
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppIPv4Address.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppIPv4Address ; \
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppIPv6Address.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppIPv6Address ; \
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppVxlanTunnelDetails.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppVxlanTunnelDetails ; \
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppConn.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppConn ;
+
+japi/vppapi.c: japi/org_openvpp_vppjapi_vppConn.h
+ pushd .. ; dir=`pwd` ; popd ; \
+ instdir=`echo $${dir} | sed -e 's:build-root/build:build-root/install:'` ; \
+ vppapigen --input $${instdir}/../vpp/api/vpe.api --jni japi/vppapi.c --app vpe ; \
+ vppapigen --input $${instdir}/../vpp/api/vpe.api --java japi/vppApi.java --app vpe ; \
+ $(JAVAC) -classpath . -d . japi/vppApi.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppApi ; \
+ $(JAVAC) -classpath . -d . @srcdir@/japi/org/openvpp/vppjapi/vppApiCallbacks.java ; \
+ $(JAVAH) -classpath . -d japi org.openvpp.vppjapi.vppApiCallbacks ;
+
+demo = japi/test/demo.class
+$(demo): $(jarfile)
+ $(JAVAC) -cp $(jarfile) -d $(JAVAROOT) @srcdir@/japi/test/demo.java
+
+all-local: $(jarfile) $(demo)