aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/Makefile.am
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2016-02-24 11:29:06 -0500
committerDave Barach <dave@barachs.net>2016-02-24 11:30:44 -0500
commit1f49ed666af8b9cb889f9ea61f084341d0b6c4f4 (patch)
tree0e951e3cc6a21f7320084a6b5f0e213f1852b634 /vpp/Makefile.am
parent9f50b0b5b12c0e1b01f36cf84070549911197584 (diff)
Link the vpp application against libvnet.so, not libvnet.a
Turn of srp, mainly as an example of how to restructure a featurette for selective disablement. Change-Id: Id3364c58a8711b103939f4434adfa67177380f67 Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'vpp/Makefile.am')
-rw-r--r--vpp/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/vpp/Makefile.am b/vpp/Makefile.am
index 0f2cf83f9b0..15f8d126fe7 100644
--- a/vpp/Makefile.am
+++ b/vpp/Makefile.am
@@ -64,12 +64,10 @@ app/version.h:
vpp_LDADD = -lvlibapi -lvlibmemory -lvlib_unix -lvlib
-vpp_LDADD += -l:libvnet.a
+vpp_LDADD += -lvnet
vpp_LDADD += -lsvm -lsvmdb -lrt
-vpp_LDADD += -lvnetplugin
-
if WITH_DPDK
vpp_LDADD += -l:libdpdk.a
endif