aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/Makefile.am
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-04-01 12:34:24 +0200
committerDamjan Marion <damarion@cisco.com>2016-04-01 16:38:33 +0200
commitaa04a0ff8ee9aa7779b30e936f7fe1304c613d57 (patch)
tree6df3e0c635db20a4569ad651e9cfdfb4be76b086 /vpp/Makefile.am
parent102ec52bc41c630f011884250e0f20ea49ac6d33 (diff)
Add option to link DPDK dynamically
Change-Id: Ie2b47f9020c8260b199d141103318a0261e16832 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'vpp/Makefile.am')
-rw-r--r--vpp/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/vpp/Makefile.am b/vpp/Makefile.am
index b66daec9477..bd2d30a9b70 100644
--- a/vpp/Makefile.am
+++ b/vpp/Makefile.am
@@ -71,8 +71,12 @@ vpp_LDADD += -lsvm -lsvmdb -lrt
vpp_LDADD += -lvnetplugin
if WITH_DPDK
+if ENABLE_DPDK_SHARED
+vpp_LDADD += -ldpdk
+else
vpp_LDADD += -l:libdpdk.a
endif
+endif
vpp_LDADD += -lvppinfra -lm -lpthread -ldl