aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/configure.ac
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-12-23 22:42:41 +0100
committerDamjan Marion <dmarion.lists@gmail.com>2016-12-26 14:53:35 +0000
commit696f1adec0df3b8f161862566dd9c86174302658 (patch)
tree0b7d382a829d573174838feb6e78a3fcba920627 /vpp/configure.ac
parent7d221611e19679fc4673f2a1d4f24d6002c2f105 (diff)
dpdk: Add support for Mellanox ConnectX-4 devices
Due to external library dependency support for Mellanox devices is disabled. To enable it uncoment following line: vpp_uses_dpdk_mlx5_pmd = yes in build-data/platforms/vpp.mk and install OFED libraries. Change-Id: I131d52b5d449a958349f31f9cc04311948f78b71 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'vpp/configure.ac')
-rw-r--r--vpp/configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/vpp/configure.ac b/vpp/configure.ac
index 2ade3d2a04d..8c333fd1679 100644
--- a/vpp/configure.ac
+++ b/vpp/configure.ac
@@ -14,6 +14,11 @@ AC_ARG_WITH(dpdk_crypto,
[with_dpdk_crypto=1],
[with_dpdk_crypto=0])
+AC_ARG_WITH(dpdk_mlx5_pmd,
+ AC_HELP_STRING([--with-dpdk-mlx5-pmd],[Use Mellanox ConnetxX-4 DPDK PMD]),
+ [with_dpdk_mlx5_pmd=1],
+ [with_dpdk_mlx5_pmd=0])
+
AC_ARG_ENABLE(dpdk-shared,
AC_HELP_STRING([--enable-dpdk-shared],[Link with DPDK shared lib]),
[enable_dpdk_shared=1],
@@ -44,7 +49,7 @@ AM_CONDITIONAL(ENABLE_DPDK_SHARED, test "$enable_dpdk_shared" = "1")
AC_SUBST(DPDK,["-DDPDK=${with_dpdk} -DDPDK_SHARED_LIB=${enable_dpdk_shared}"])
AM_CONDITIONAL(WITH_DPDK_CRYPTO, test "$with_dpdk_crypto" = "1")
AC_SUBST(DPDK_CRYPTO,[-DDPDK_CRYPTO=${with_dpdk_crypto}])
-
+AM_CONDITIONAL(WITH_DPDK_MLX5_PMD, test "$with_dpdk_mlx5_pmd" = "1")
AM_COND_IF(
[ENABLE_DPDK_SHARED],