aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/configure.ac
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2016-12-14 14:49:55 -0500
committerDamjan Marion <dmarion.lists@gmail.com>2016-12-23 17:38:09 +0000
commitfc262a0cf77e3c14ff1d6c006e7eac70999b926f (patch)
treecdd49ff1071660af24c8d5b4d11425681ae870a3 /vpp/configure.ac
parent6c7440ca95fe3508c083ac4d2ecf7eca459b7f8e (diff)
Build vpp_api_test binary API debug CLI into vpp
Change-Id: I60ce73a62d8632a644fbfdfbe13ff8ddbb959233 Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'vpp/configure.ac')
-rw-r--r--vpp/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/vpp/configure.ac b/vpp/configure.ac
index d36695cc1fe..2ade3d2a04d 100644
--- a/vpp/configure.ac
+++ b/vpp/configure.ac
@@ -34,6 +34,11 @@ AC_ARG_WITH(ipv6sr,
[with_ipv6sr=0],
[with_ipv6sr=1])
+AC_ARG_WITH(apicli,
+ AC_HELP_STRING([--without-apicli],[Disable binary api CLI]),
+ [with_apicli=0],
+ [with_apicli=1])
+
AM_CONDITIONAL(WITH_DPDK, test "$with_dpdk" = "1")
AM_CONDITIONAL(ENABLE_DPDK_SHARED, test "$enable_dpdk_shared" = "1")
AC_SUBST(DPDK,["-DDPDK=${with_dpdk} -DDPDK_SHARED_LIB=${enable_dpdk_shared}"])
@@ -64,4 +69,7 @@ AC_SUBST(VCGN,[-DVCGN=${with_vcgn}])
AM_CONDITIONAL(WITH_IPV6SR, test "$with_ipv6sr" = "1")
AC_SUBST(IPV6SR,[-DIPV6SR=${with_ipv6sr}])
+AM_CONDITIONAL(WITH_APICLI, test "$with_apicli" = "1")
+AC_SUBST(APICLI,[-DVPP_API_TEST_BUILTIN=${with_apicli}])
+
AC_OUTPUT([Makefile])