aboutsummaryrefslogtreecommitdiffstats
path: root/vppapigen/Makefile.am
diff options
context:
space:
mode:
authorEd Warnicke <eaw@cisco.com>2015-12-08 15:45:58 -0700
committerEd Warnicke <eaw@cisco.com>2015-12-08 15:47:27 -0700
commitcb9cadad578297ffd78fa8a33670bdf1ab669e7e (patch)
tree6ac2be912482cc7849a26f0ab845561c3d7f4e26 /vppapigen/Makefile.am
parentfb0815d4ae4bb0fe27bd9313f34b45c8593b907e (diff)
Initial commit of vpp code.v1.0.0
Change-Id: Ib246f1fbfce93274020ee93ce461e3d8bd8b9f17 Signed-off-by: Ed Warnicke <eaw@cisco.com>
Diffstat (limited to 'vppapigen/Makefile.am')
-rw-r--r--vppapigen/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/vppapigen/Makefile.am b/vppapigen/Makefile.am
new file mode 100644
index 00000000000..42530015ea9
--- /dev/null
+++ b/vppapigen/Makefile.am
@@ -0,0 +1,28 @@
+# Copyright (c) 2015 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS = vppapigen
+
+BUILT_SOURCES = gram.h
+
+gram.h: gram.y
+ $(YACC) -d @srcdir@/gram.y
+ mv y.tab.h gram.h
+ rm y.tab.c
+
+vppapigen_SOURCES = gram.y lex.c node.c
+vppapigen_CPPFLAGS =
+vppapigen_LDADD = -lvppinfra
+vppapigen_LDFLAGS = -static