aboutsummaryrefslogtreecommitdiffstats
path: root/vppinfra/configure.ac
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2016-12-19 23:05:39 +0100
committerDamjan Marion <damarion@cisco.com>2016-12-28 12:25:14 +0100
commit7cd468a3d7dee7d6c92f69a0bb7061ae208ec727 (patch)
tree5de62f8dbd3a752f5a676ca600e43d2652d1ff1a /vppinfra/configure.ac
parent696f1adec0df3b8f161862566dd9c86174302658 (diff)
Reorganize source tree to use single autotools instance
Change-Id: I7b51f88292e057c6443b12224486f2d0c9f8ae23 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'vppinfra/configure.ac')
-rw-r--r--vppinfra/configure.ac52
1 files changed, 0 insertions, 52 deletions
diff --git a/vppinfra/configure.ac b/vppinfra/configure.ac
deleted file mode 100644
index 88939383057..00000000000
--- a/vppinfra/configure.ac
+++ /dev/null
@@ -1,52 +0,0 @@
-# Process this file with autoconf to produce a configure script.
-AC_INIT(libvppinfra,1.0,)
-AC_CONFIG_AUX_DIR(config)
-AC_CONFIG_HEADERS(config/config.h)
-AC_CANONICAL_BUILD
-AC_CANONICAL_HOST
-AM_INIT_AUTOMAKE([gnu no-dist-gzip dist-bzip2])
-AM_SILENT_RULES([yes])
-
-# Checks for programs.
-AC_PROG_CC
-AM_PROG_AS
-AM_PROG_LIBTOOL
-
-######################################################################
-
-dnl ------------
-dnl Check CFLAGS, CC
-dnl ------------
-AC_ARG_WITH(cc,
- AC_HELP_STRING([--with-cc],[Set CC for use as C compiler.]),
- [CC="$with_cc"])
-
-AC_ARG_WITH(cflags,
- AC_HELP_STRING([--with-cflags],[Set CFLAGS for use by C compiler.]),
- [CFLAGS="$with_cflags"])
-
-AC_ARG_WITH(ldflags,
- AC_HELP_STRING([--with-ldflags],[Set LDFLAGS for linking.]),
- [LDFLAGS="$with_ldflags"])
-
-######################################################################
-
-AC_ARG_ENABLE(tests,
- AC_HELP_STRING([--enable-tests],[Enable unit tests]),
- [enable_tests=1],
- [enable_tests=0])
-
-AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" = "1")
-
-AC_ARG_WITH(unix,
- AC_HELP_STRING([--with-unix],[Compile unix version of clib]),
- [],
- [case $host_os in
- darwin* | linux*) with_unix=yes;;
- *) with_unix=no;;
- esac])
-
-AM_CONDITIONAL(WITH_UNIX, test "$with_unix" = "yes")
-
-AC_CONFIG_FILES([Makefile])
-AC_OUTPUT